嘘~ 正在从服务器偷取页面 . . .

RIP路由实验四


前言:

这是我老师布置的作业,花了我半天时间(还是个小菜鸡),就写了一下笔记,记录一下学习过程,我这里使用的是AR2220路由器,记住路由器之间连线使用G,用E线不能直接设置IP地址,至于为什么可以去百度。

一. 实验要求

[实验目的]

  1. 掌握路由器的互联与设置
  2. 熟悉动态路由协议RIP的配置

[实验要求]

  1. 根据拓扑图完成路由器、PC机的基本配置
    1. 启用RIP V2版本实现全网的连通
    2. 在路由器R1上启用一个loopback虚拟端口
    3. 在三台路由器分别显示路由表并截图
    4. 在PC1 上分别ping PC2 PC3并截图

[实验报告要求]

  1. R1和R2之间IP地址采用B类的私有地址块,第 三个字节必须为自己学号后两位,其它地址自定。
  2. 实验拓扑图中要表明各个设备的IP地址
  3. R1路由器的loopback口地址为:
    学号后两位.1.1.1 255.255.255.255
  4. 实验拓扑图和测试结果的截图写入实验报告

实验拓扑

在这里插入图片描述

二. 配置IP

AR1

<Huawei>undo terminal monitor 
<Huawei>sys
[Huawei]int g0/0/1
[Huawei-GigabitEthernet0/0/1]ip address 172.16.6.1 24
[Huawei-GigabitEthernet0/0/1]q
[Huawei]int g0/0/2
[Huawei-GigabitEthernet0/0/2]ip address 192.168.6.1 24
[Huawei-GigabitEthernet0/0/2]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip address 172.16.7.1 24
[Huawei]dis ip interface brief 

AR2

<Huawei>undo terminal monitor 
Info: Current terminal monitor is off.
[Huawei]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip address 172.16.8.1 24
[Huawei-GigabitEthernet0/0/0]int g0/0/1
[Huawei-GigabitEthernet0/0/1]ip address 172.16.7.2 24
[Huawei-GigabitEthernet0/0/1]int g0/0/2
[Huawei-GigabitEthernet0/0/2]ip address 192.168.7.1 24
[Huawei]dis ip interface brief 

AR3

<Huawei>undo terminal monitor 
[Huawei]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip address 172.16.8.2 24
[Huawei-GigabitEthernet0/0/0]int g0/0/2
[Huawei-GigabitEthernet0/0/2]ip add    
[Huawei-GigabitEthernet0/0/2]ip address 192.168.8.1 24
[Huawei-GigabitEthernet0/0/2]int g0/0/1
[Huawei-GigabitEthernet0/0/1]ip address 172.16.6.2 24
[Huawei-GigabitEthernet0/0/1]dis ip int bri

测试一下:

PC1 ping 192.168.6.1

PC1 ping 172.16.7.1

使用下列命令查看各个路由接口的IP是否配置正确

[Huawei]dis ip interface brief 

三.配置RIP V2

AR1

<Huawei>sys
[Huawei]rip
[Huawei-rip-1]version 2
[Huawei-rip-1]network 172.16.0.0
[Huawei-rip-1]network 192.168.6.0

AR2

[Huawei]rip
[Huawei-rip-1]version 2
[Huawei-rip-1]network 172.16.0.0
[Huawei-rip-1]network 192.168.7.0
[Huawei]display ip routing-table 

AR3

[Huawei]rip
[Huawei-rip-1]version 2
[Huawei-rip-1]network 192.168.8.0
[Huawei-rip-1]network 172.16.0.0

配置完成可以使用以下命令查看路由表

display ip routing-table 

比如AR1已经通过RIP学到了AR2和AR3的路由条目

在这里插入图片描述

我们ping一下发现联通了

在这里插入图片描述

在这里插入图片描述

四. loopback环回接口

介绍:在Router ID中的应用

​ 一些动态路由协议要求路由器必须有Router ID,它是一台路由器在自治系统中的唯一标识。

​ 例如,OSPF和BGP在没有手工配置Router ID时,系统需要从本地接口的IP地址中选一个最大的IP地址作为Router ID。如果选择的是物理接口的IP地址,当这个物理接口状态变为Down时,系统也不会重新选择Router ID,除非这个被选择的IP地址被删除。

​ 因此建议使用Loopback接口的IP地址作为路由器的Router ID。因为Loopback接口稳定,它一直都处于Up状态。

我的理解:就是给它取个假名字。然后你拿这个名字表示自己

AR1

[Huawei]int LoopBack 0
[Huawei-LoopBack0]ip address 8.1.1.1 24    
[Huawei-LoopBack0]display ip routing-table 
[Huawei]rip
[Huawei-rip-1]vers    
[Huawei-rip-1]version 2
[Huawei-rip-1]net    
[Huawei-rip-1]network 8.0.0.0

在这里插入图片描述

使用pc2ping一下

在这里插入图片描述

五. 实验结果

在这里插入图片描述

在这里插入图片描述

在这里插入图片描述

ping loopback

在这里插入图片描述在这里插入图片描述

本人博客:https://blog.csdn.net/weixin_46654114
本人b站求关注:https://space.bilibili.com/391105864
转载说明:跟我说明,务必注明来源,附带本人博客连接。

请给我点个赞鼓励我吧
在这里插入图片描述


文章作者: RodmaChen
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 RodmaChen !
评论
  目录